10 Dezember 2018, 19:19:24

Autor Thema: SIP Status 200 OK wird nicht signalisiert (QSC und 886VA)  (Gelesen 825 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

jujoi

  • Cisco Hilfsadmin
  • ***
  • Beiträge: 57
  • Karma: 0
    • Profil anzeigen
Hallo,
ich habe an meinem 1und1 VDSL Anschluss das Problem, dass seit einiger Zeit der SIP Status 200 OK bei der Annahme von eingehenden Gesprächen nicht mehr signalisiert wird. Als Router ist ein 886VA im Einsatz. In der Vergangenheit gab es keine Schwierigkeiten. 1und1 konnte das Problem nicht nachvollziehen, da die SIP Telefonie hinter der FritzBox funktioniert und das Problem nur bei Einsatz des Cisco Routers an dem Anschluss auftritt. Der Netzprovider ist QSC. Bei einem identischen 1und1 Anschluss mit dem Netzprovider Versatel gibt es keinerlei Probleme. Der Wireshark Mittschnitt gestaltet sich an der Problemleitung wie folgt:



Der SIP Port 5060 und die notwendigen RTP Ports sind auf das SIP Telefon weitergeleitet. Wenn ich den Audio Codec PCMU provoziere, wird die Verbindung ohne Probleme aufgebaut. Jedoch gibt es dann ein Echo in der Leitung. Sobald ich PCMA verwende, klappt es nicht mehr. Die Router Konfiguration sieht verkürzt wie folgt aus:

interface Ethernet0
 no ip address

interface Ethernet0.7
 encapsulation dot1Q 7
 pppoe enable group global
 pppoe-client dial-pool-number 1

interface Vlan1
 ip address 10.11.1.1 255.255.255.0
 ip nat inside
 no ip virtual-reassembly in
 ip tcp adjust-mss 1452

interface Dialer0
 ip address negotiated
 ip nat outside
 ip virtual-reassembly in
 encapsulation ppp
 dialer pool 1
 ppp authentication chap callin
 ppp chap hostname username@online.de
 ppp chap password 0 12345678
 ppp ipcp dns request
 no cdp enable

ip nat inside source static udp 10.11.1.3 5060 interface Dialer0 5060
ip nat inside source static tcp 10.11.1.3 5060 interface Dialer0 5060
ip nat inside source static udp 10.11.1.3 16384-16390 interface Dialer0 16384-16390

ip nat inside source route-map NAT interface Dialer0 overload

ip route 0.0.0.0 0.0.0.0 Dialer0

ip access-list extended NAT-ACL
 permit ip 10.11.1.0 0.0.0.255 any

route-map NAT permit 1
 match ip address NAT-ACL

Das debug ip nat des Verbindungsaufbaus habe ich angehängt. Ich bin mittlerweile seit mehreren Tagen auf der Suche und verstehe nicht, warum das SIP Status 200 OK bei dem Versuch der Gesprächsannahme nicht erfolgreich gesendet werden kann. Wie gesagt, an einem identischen 1und1 Anschluss mit dem Netzprovider Versatel gibt es keinerlei Schwierigkeiten mit dem Setup.

Ich bin für jeden Einweis wirklich sehr dankbar.

wwinzig

  • Cisco Hilfsadminvertretung
  • **
  • Beiträge: 26
  • Karma: 1
    • Profil anzeigen
Re: SIP Status 200 OK wird nicht signalisiert (QSC und 886VA)
« Antwort #1 am: 28 Oktober 2018, 15:11:22 »
Was für eine Firewall nutzt du auf dem 886 ?
Normalerweise taucht das Problem mit der (alten) CBAC basierten Firewall nicht auf !
Es passiert nur wenn man die neue ZFW basierte Firewall nutzt und eine SIP Inspection macht.
Siehe dazu auch hier:
https://www.administrator.de/wissen/cisco-880-890-router-konfiguration-adsl-vdsl-anschluss-inkl-vpn-ip-tv-179345.html
Die ZFW Firewall mag manche SIP Kommunikation einzelner Provider nicht.
Helfen tut hier in der Regel immer eine STUN Konfig zu nutzen (STUN Server angeben im Telefon oder Anlagen Setup) oder noch einfacher einfach die SIP Inspection rauszunehmen.
SIP Pakete werden dann über die ganz normale TCP oder UDP Inspection in der ZFW mit abgefackelt und das beseitigt dann die Fehlermeldung im Log.

Deutschsprachiges Cisco Forum

Re: SIP Status 200 OK wird nicht signalisiert (QSC und 886VA)
« Antwort #1 am: 28 Oktober 2018, 15:11:22 »

 


SimplePortal 2.3.2 © 2008-2010, SimplePortal