22 Juli 2018, 16:33:31

Autor Thema: wktools 4.7.x nicht unter Windows XP lauffähig  (Gelesen 5154 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

c1sc0

  • Cisco User
  • *
  • Beiträge: 3
  • Karma: 0
    • Profil anzeigen
wktools 4.7.x nicht unter Windows XP lauffähig
« am: 08 April 2013, 18:14:41 »
Hallo Mathias,

ich habe die Version 4.6.1.0 unter XP getestet - leider sind alle 4.7er Versionen unter Windows XP nicht lauffähig ("keine zulässige win32-Anwendung").
Könnte dies evtl. am Einsatz von Visual Studio 2012 und dem C++ Runtime Support (v110_xp toolset) liegen?
http://blogs.msdn.com/b/vcblog/archive/2012/10/08/10357555.aspx

Version 4.6.1.0 finde ich echt Klasse - leider fehlt hier der NX-OS-Support beim Mapper, den ich gern ausprobieren würde.

Beste Grüße

c1sc0

#9370

  • Global Moderator
  • Cisco Veteran mit Auszeichnung
  • **
  • Beiträge: 3.703
  • Karma: 65
  • CCIE #9370
    • Profil anzeigen
    • wktools
Re: wktools 4.7.x nicht unter Windows XP lauffähig
« Antwort #1 am: 09 April 2013, 10:17:17 »
Hallo,

ja, du musst das "Visual C++ Redistributable für Visual Studio 2012" installieren (32Bit Version). Das braucht es leider, da ich mit der 4.7er Release auf VS 2012 umgestiegen bin.
https://www.microsoft.com/de-at/download/details.aspx?id=30679

/Mathias
-- www.spoerr.org/wktools --

Keine Anfragen per Private Nachricht
Fragen werden nur im Forum beantwortet!

Sharky

  • Cisco Adminvertretung
  • ****
  • Beiträge: 235
  • Karma: 8
    • Profil anzeigen
Re: wktools 4.7.x nicht unter Windows XP lauffähig
« Antwort #2 am: 09 April 2013, 11:43:15 »
Ich habe das gleiche Problem auf einem Windows XP Sytem. Windows 7 funktioniert prima.

Ich kann das Paket gar nicht erst installieren, weil eine DLL fehlt.

vcredist_x86.exe framedyn.dll fehlt . Bisher habe ich keine Lösung gefunden.

CCNA, ROUTE, study for SWITCH , follow me on twitter @dersharky

#9370

  • Global Moderator
  • Cisco Veteran mit Auszeichnung
  • **
  • Beiträge: 3.703
  • Karma: 65
  • CCIE #9370
    • Profil anzeigen
    • wktools
Re: wktools 4.7.x nicht unter Windows XP lauffähig
« Antwort #3 am: 09 April 2013, 13:33:50 »
Hmm - das ist eigenartig, denn laut Microsoft sollte das auch auf XP unterstützt sein. Ich werde mal mehr nachforschen und gebe euch Bescheid.

/Mathias
-- www.spoerr.org/wktools --

Keine Anfragen per Private Nachricht
Fragen werden nur im Forum beantwortet!

c1sc0

  • Cisco User
  • *
  • Beiträge: 3
  • Karma: 0
    • Profil anzeigen
Re: wktools 4.7.x nicht unter Windows XP lauffähig
« Antwort #4 am: 09 April 2013, 13:59:10 »
Hallo,

das "Visual C++ Redistributable für Visual Studio 2012" hatte ich installiert - so wie ich die Aussagen verstehe, muss das Toolset v110_xp in den Einstellungen des Visual Studios ausgewählt werden, damit die Anwendung kompatibel zu Windows XP ist.

"In order to target Windows XP, switch from the default v110 toolset to the newly introduced v110_xp toolset inside your project’s property pages. This new platform toolset points to a repackaged version of the Windows 7 SDK shipped in Visual Studio 2010 instead of the Windows 8 SDK, but uses the same Visual Studio 2012 compiler."

Beste Grüße

c1sc0

#9370

  • Global Moderator
  • Cisco Veteran mit Auszeichnung
  • **
  • Beiträge: 3.703
  • Karma: 65
  • CCIE #9370
    • Profil anzeigen
    • wktools
Re: wktools 4.7.x nicht unter Windows XP lauffähig
« Antwort #5 am: 09 April 2013, 14:22:16 »
danke für den Hinweis. Ich habe es mal so erstellt (Version 4.7.5.5). Könntet ihr das bitte probieren:
www.spoerr.org/wktools/download/wktools4.7.5.5.zip

Danke,
/Mathias
-- www.spoerr.org/wktools --

Keine Anfragen per Private Nachricht
Fragen werden nur im Forum beantwortet!

c1sc0

  • Cisco User
  • *
  • Beiträge: 3
  • Karma: 0
    • Profil anzeigen
Re: wktools 4.7.x nicht unter Windows XP lauffähig
« Antwort #6 am: 10 April 2013, 12:44:49 »
Hallo,

beim ausführen des Mappers erhalte ich den Fehler

6305: Parser Error! Code 0052 - Contact ...
SELECT intf_id FROM interfaces INNER JOIN devInterface ON devInterface.interfaces_int_id=interfaces.intf_id INNER JOIN device ON device.dev_id=d [geht noch weiter, allerdings ist mein Bildschirm nicht breiter - im LogFile für den Output steht nichts]
6610: Searching file E:\[Pfad und Name der Gerätedatei, die vorhanden ist]

Außerdem erscheint eine Meldung der Microsoft Visual C++ Runtime Library:

Runtime Error!
Program: E:\wktools4.7.5.5\wktools4.exe
abnormal program termination

Das "Einsammeln" (show-Befehle und Schreiben der Gerätedateien (*.txt)) läuft durch, jedoch werden zwischendurch auch Fehler angezeigt, die allerdings nicht zum Abbruch des Programms führen.

Grüße

c1sc0

#9370

  • Global Moderator
  • Cisco Veteran mit Auszeichnung
  • **
  • Beiträge: 3.703
  • Karma: 65
  • CCIE #9370
    • Profil anzeigen
    • wktools
Re: wktools 4.7.x nicht unter Windows XP lauffähig
« Antwort #7 am: 10 April 2013, 13:38:25 »
Hallo,

kannst du mir bitte das File schicken, bei dem das Tool crasht?

Danke,
Mathias
-- www.spoerr.org/wktools --

Keine Anfragen per Private Nachricht
Fragen werden nur im Forum beantwortet!

Sharky

  • Cisco Adminvertretung
  • ****
  • Beiträge: 235
  • Karma: 8
    • Profil anzeigen
Re: wktools 4.7.x nicht unter Windows XP lauffähig
« Antwort #8 am: 10 April 2013, 15:59:40 »
Hey Mathias,

mit der neuen Version startet das Programm schonmal. Sobald ich aber versuche meine Hostdatei zuladen hängt das komplette Programm.


Würde dir gerne Logdateien schicken, aber ich weiß nicht wo Windows crash reports ablegt.

Gruß !
CCNA, ROUTE, study for SWITCH , follow me on twitter @dersharky

#9370

  • Global Moderator
  • Cisco Veteran mit Auszeichnung
  • **
  • Beiträge: 3.703
  • Karma: 65
  • CCIE #9370
    • Profil anzeigen
    • wktools
Re: wktools 4.7.x nicht unter Windows XP lauffähig
« Antwort #9 am: 10 April 2013, 17:59:09 »
Hallo,

das kann damit zu tun haben, dass ich nur das Programm selber mit der Option erstellt habe, aber die ganzen verwendeten Libs nicht. Ich muss mal schauen, was ich da machen kann, denn mit den Libs wird das sehr aufwändig.
Windows7 ist keine Option?

/Mathias
-- www.spoerr.org/wktools --

Keine Anfragen per Private Nachricht
Fragen werden nur im Forum beantwortet!

#9370

  • Global Moderator
  • Cisco Veteran mit Auszeichnung
  • **
  • Beiträge: 3.703
  • Karma: 65
  • CCIE #9370
    • Profil anzeigen
    • wktools
Re: wktools 4.7.x nicht unter Windows XP lauffähig
« Antwort #10 am: 19 April 2013, 22:53:06 »
Hallo,

ich habe mich dazu entschlossen, Windows XP nicht mehr zu unterstützen, da Microsoft den Support nächstes Jahr sowieso einstellt und der Aufwand nicht dafürsteht (Eigener Build für XP + Eigener Build für alle verwendeten Libs).

Tut mir leid,
/Mathias
-- www.spoerr.org/wktools --

Keine Anfragen per Private Nachricht
Fragen werden nur im Forum beantwortet!

Sharky

  • Cisco Adminvertretung
  • ****
  • Beiträge: 235
  • Karma: 8
    • Profil anzeigen
Re: wktools 4.7.x nicht unter Windows XP lauffähig
« Antwort #11 am: 21 April 2013, 16:40:52 »
Hallo Matthias,

ist doch nur verständlich. Irgendwann muss ja auch unsere IT mal auf Windows 7 umsteigen ;)

Gruß !
CCNA, ROUTE, study for SWITCH , follow me on twitter @dersharky

Deutschsprachiges Cisco Forum

Re: wktools 4.7.x nicht unter Windows XP lauffähig
« Antwort #11 am: 21 April 2013, 16:40:52 »

 


SimplePortal 2.3.2 © 2008-2010, SimplePortal